Внедрения системы штрихкодирования товаров и документов для автоматизации учета. «1С:Розница»: осваиваем штрихкоды Использование штрих код в 1с

Штрихкодирование документов в 1С 8.3 (8.2)

Внедрения системы штрихкодирования товаров и документов для автоматизации учета. «1С:Розница»: осваиваем штрихкоды Использование штрих код в 1с

Рассмотрим подключение подсистемы штрихкодирования документов на примере подключения такого механизма в конфигурации 1С 8.2 и 8.3 Управление торговлей.

Зачем нужно штрихкодирование документов в 1С?

Штрихкодирование документов может понадобиться для наведения порядка в бумажном документообороте — любому бумажному документу за считанные секунды можно найти электронный аналог в системе. Например, очень удобно, когда клиенты приходят в офис с уже распечатанным заказом, в котором есть штрих-код, — в этом случае обслуживание клиента занимает существенно меньше времени.

Настройка штрихкодирования документов 1С

Первый шаг к настройке штрихкодирования — создание штрих-кода, хранение его в базе данных и распечатка на бумажном носителе.

Генерация штрих-кода и сохранение его в 1С

Для хранения штрих-кода создадим у документа новый реквизит — назовём его «штрихкод».

С генерацией нового штрих-кода немного труднее. Необходимо воспользоваться процедурой РаботаСТорговымОборудованием.СформироватьШтрихКод() из конфигурации управление торговлей и сформировать его перед записью нового документа:

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения) ….. Если ЭтоНовый() Тогда Штрихкод = РаботаСТорговымОборудованием.СформироватьШтрихКод(); КонецЕсли; ….. КонецПроцедуры;

Распечатка штрих-кода на печатной форме описана в отдельной статье — вывод на печатную форму штрих-кода.

Если вы только начинаете программировать в 1С или просто хотите систематизировать свои знания — попробуйте Школу программирования 1С нашего друга Владимира Милькина. Пошаговые и понятные уроки даже для новичка с поддержкой учителя.
Попробуйте бесплатно по ссылке >>

С установкой, хранением и распечаткой документов мы разобрались. Перейдем к другому этапу — поиск документов по штрих-коду.

Настройка поиска документа в 1С по штрих-коду

Рассмотрим поиск документа по штрих-коду из формы списка документа «Заказ покупателю».

Первым делом необходимо скопировать из других форм (например, форма списка номенклатуры), отвечающих за работу с внешним оборудованием — сканером штрих-кода. Вот процедуры, которые необходимо поместить в форму списка:

Процедура ВнешнееСобытие(Источник, Событие, Данные) ПолучитьСерверТО().ОбработатьВнешнееСобытие(Источник, Событие, Данные, ЭтаФорма); КонецПроцедуры Функция ПоддерживаетсяВидТО(Вид) Экспорт Результат = Ложь; Если Вид = Перечисления.ВидыТорговогоОборудования.

СканерШтрихКода Тогда Результат = Истина; КонецЕсли; Возврат Результат; КонецФункции // ПоддерживаетсяВидТО() Функция СШКНоменклатура(Номенклатура, Характеристика, Серия, Качество, Единица, Количество, СШК) Экспорт Результат = Истина; Возврат Результат; КонецФункции // СШКНоменклатура() Функция СШКСерийныйНомер(Номер, СШК) Экспорт Возврат Истина; КонецФункции // СШКСерийныйНомер() Функция СШКИнформационнаяКарта(Карта, СШК) Экспорт Результат = Истина; Возврат Результат; КонецФункции // СШКИнформационнаяКарта() Функция СШКНеизвестныйКод(Штрихкод, ТипКода, СШК) Экспорт НайтиЗаказПоШтрихкоду(Штрихкод); Возврат Истина; КонецФункции // СШКНеизвестныйКод() Процедура СШКОшибка(Ошибка, Штрихкод, ТипШК, СШК) Экспорт Текст = ПолучитьСерверТО().ПолучитьТекстОшибкиСШКТО(Ошибка, Штрихкод, ТипШК); Предупреждение(Текст); КонецПроцедуры // СШКОшибка()

Обратите внимание на процедуру СШКНеизвестныйКод, если стандартные механизмы не смогли найти номенклатуру, они вернут нас в функцию «СШКНеизвестныйКод», где мы его и обработаем.

Опишем процедуру НайтиЗаказПоШтрихкоду, с помощью которой мы найдем нужный документ по штрих-коду и откроем его форму:

Процедура НайтиЗаказПоШтрихкоду(ТекШтрихкод) Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | ЗаказПокупателя.Ссылка |ИЗ | Документ.ЗаказПокупателя КАК ЗаказПокупателя |ГДЕ | ЗаказПокупателя.Штрихкод= &Штрихкод»; Запрос.УстановитьПараметр(«Штрихкод», ТекШтрихкод); Результат = Запрос.Выполнить(); Если Результат.

Пустой() Тогда Сообщить(«Заказ с штрихкодом » + ТекШтрихкод + » не найден»); Возврат; Иначе Выборка = Результат.Выбрать(); Выборка.Следующий(); СсылкаНаДокумент = Выборка.Ссылка; СсылкаНаДокумент.ПолучитьФорму().Открыть(); КонецЕсли; КонецПроцедуры

При выполнении данной процедуры будет происходить поиск нужного заказа по штрих-коду.

Если заказ найден по штрих-коду, то система откроет заказ, не найден — сообщит об этом.

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

Источник: https://programmist1s.ru/poisk-dokumentov-po-shtrihkodu-v-1s/

Вопросы адвокату
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: