1с добавление штрих кода. «1С:Розница»: осваиваем штрихкоды. Оправданность перемаркировки товаров собственными штрихкодами

1С:Розница: маркировка остатков обуви

1с добавление штрих кода. «1С:Розница»: осваиваем штрихкоды. Оправданность перемаркировки товаров собственными штрихкодами
Нас часто спрашивают, можно ли продать в программе «1С:Розница» обувь, если марки получены, распечатаны и введены в оборот в личном кабинете Информационной системы маркировки товаров (ЛК ИС МП) на сайте «Честный знак». Да, можно! Причем начинать использовать программу можно на любом этапе процесса.

Для того, чтобы все получилось, нужно:

  1. Пересчитать обувь в магазине;
  2. Зафиксировать результат;
  3. Заказать марки;
  4. Распечатать и наклеить на коробки;
  5. Отчитаться о проделанной работе в ЛК ИСМП – ввести марки в оборот.

Можно продавать!

Теперь подробнее о каждом шаге.

Пересчет остатков обуви в магазине

Пересчитывать обувь в магазине нужно не просто по количеству, а распределяя коробки по 8-ми категориям остатков.

По виду продукции:

  • мужская;
  • женская;
  • детская;
  • унисекс (спортивная, домашние шлепки).

По стране происхождения:

  • отечественная;
  • импортная.

На каждую из восьми категорий участнику оборота необходимо получить GTIN (Global Trade Item Number) – уникальный номер товарной категории остатков. Несмотря на то, что категории остатков одинаковые, GTIN разные для разных владельцев товара.

Если вы уже используете программу «Розница», то она может помочь определить учетные остатки по этим категориям. Для этого в разделе Склад нужно создать Приказ на пересчет товаров для каждого магазина и склада.

Далее выбрать тип схемы компоновки Произвольная и ввести дополнительные фильтры, в зависимости от того, как структурируется товарная масса в базе данных. Например, с помощью дополнительных справочников:

  • Группа номенклатуры,
  • Товарная группа,
  • Ценовая группа,
  • Список Торговых марок поможет разделить обувь на отечественную и импортную.

Главное – не пропустить какой-либо группы. Проконтролировать остатки можно с помощью отчета «Остатки на складах».

Не лишним будет напомнить, что для проведения инвентаризации остатков на складах и в торговых залах магазинов должны быть завершены все складские операции – как физически, так и в программе.

Далее переходим к заказу марок.

Заказ марок

Владелец может заказать марки двумя способами – из программы 1С:Розница и непосредственно в ЛК ИС МП. Заказ марок в личном кабинете никак не помешает продаже через кассу.

Для заказа марок из программы необходимо установить признак использования интеграционного интерфейса – Вести учет обувной продукции (Администрирование – Настройки интеграции с ИС МП).

В этой статье мы опускаем вопросы настройки подключения к СУЗ. Они подробно описаны в статье Маркировка обуви.

В разделах Закупки, Склад, Продажи появляется пункт Обмен с ИС МП, с помощью которого запускается форма работы с документами маркировки. В списке Заказы на эмиссию кодов маркировки СУЗ нужно создать новый документ, выбрать организацию и способ ввода в оборот – Маркировка остатков.

На закладке Основное с помощью флажков указываем, что номенклатуру сопоставлять не будем и, что товар произведен/приобретен до 01.07.20.

Затем на закладке Товары необходимо ввести столько товарных строк, сколько товарных категорий остатков нашлось в данном магазине – то есть, не более восьми.

Для каждой строки выбрать из выпадающего списка код ТН ВЭД (например, 6403999100, 6403999300, 6403999600, 6403999800), вид обуви и способ ввода в оборот.

GTIN на остаток нужно запросить в ИС МП по гиперссылке, после чего наименование номенклатуры в строке сформируется автоматически в соответствии с выбранными параметрами. Все коды остатков начинаются с «029….».

При оформлении последующих документов запрашивать GTIN уже не понадобится, если в первом же документе были все 8 категорий.

Затем необходимо запросить коды маркировки с помощью ссылки и после ответа ИС МП перейти к печати этикеток с помощью команды Печать.

Печать марок

Распечатывать марки можно как на обычном офисном принтере, так и на принтере этикеток. Нужно только соответствующим образом настроить вывод марок – либо замостить, либо вывести на отдельных листах.

Все этикетки имеют одно и то же наименование, соответствующее категории остатков, например, «Остаток.Обувь.Женская.Произведена в РФ», один и тот же номер GTIN, но разные коды маркировки для каждой пары обуви. В этом можно убедиться, внимательно рассмотрев символы во второй строке подписи под квадратным кодом DataMatrix.

Сам же квадратик DataMatrix – это графический формат кода марки, который будет считываться сканером при продаже. В этом штриховом коде записаны не только код категории остатка и серийный номер обувной пары, но и криптографическая подпись — «криптохвост», который удостоверяет легальность этой марки.

Распечатанные марки можно отправить в магазин, нарезать и расклеить на коробки. Конечно, все это время, пока мы запрашивали и печатали марки в офисе, магазины продолжали работать, поэтому к тому моменту, когда все готово к расклеиванию марок по обувным коробкам, их количество может несколько уменьшиться. Ничего страшного, собираем оставшиеся марки в файлик и отправляем обратно в офис.

Ввод марок в оборот

Осталось ввести марки в оборот. Для этого следует создать документ Маркировка товаров ИС МП, выбрать организацию и операцию — Маркировка остатков, и, перейдя на закладку Товары, вызвать форму подбора и проверки маркированной продукции.

Далее, с помощью пиктограммы  вызываем список «Заказов на эмиссию кодов маркировки СУЗ» и выбираем нужный нам документ. При этом таблица заполнится кодами маркировки, полученными этим документом. Дальше есть выбор – сразу же ввести все коды маркировки в оборот или дождаться файлик с излишками марок из магазинов.

В первом случае будет введено в оборот избыточное количество кодов. Но в этом нет ничего страшного, так как впоследствии эти лишние коды можно будет либо использовать взамен утраченных, либо вывести из оборота списанием.

Во втором случае нам нужно найти и вычеркнуть из списка лишние коды марок. Для этого подключаем сканер и считываем последовательно их коды. При этом в списке выделяется строка с маркой, ее можно удалить клавишей Delete.

Либо включить режим Удалять коды при сканировании (см. рис. выше).

В этом случае коды будут удаляться при считывании автоматически, а за процессом удобно следить на закладке Обувная продукция, где информация о марках свернута по категориям остатков и при удалении марок уменьшается их количество.

В обоих вариантах после завершения подбора ввод в оборот осуществляется с помощью ссылки передайте данные.

В программе можно ввести в оборот и марки, заказанные в личном кабинете участника оборота. Правда, если коды не сохранены в каком-нибудь файле Excel, например, то сделать это несколько сложнее.

Перед тем как отправлять распечатанные марки в магазин, нужно отсканировать их в документ Маркировка товаров ИС МП.

Либо применить терминал сбора данных, считать на складе уже расклеенные марки и загрузить информацию в таблицу. Вариантов много.

После ввода марок в оборот можно продавать маркированный товар в розницу.

Продажа маркированной обуви через РМК

Поведение программы зависит от разных обстоятельств:

  • наступила ли дата, после которой продажа немаркированной обуви запрещена;
  • имеет ли обувь промышленный штрихкод или это пластиковые шлепки, у которых и упаковки-то нет;
  • эмитированы марки для каждого артикула и размера, как при производстве или остатки промаркированы упрощенным, описанным в этой статье способом;
  • наконец, нанесены ли марки на коробки.

Разберемся со всеми ситуациями подробнее.

Программа должна как-то узнать, что остатки обуви теперь маркированные. Для этого все виды номенклатуры, относящиеся к обуви, должны стать маркируемой обувной продукцией.

Для этого разрешаем редактирование существующего вида номенклатуры и изменяем тип номенклатуры, сохраняем запись. В этот момент программа запросит разрешение на изменение параметров связанной с этим видом карточек номенклатуры. Нужно согласиться.

Теперь нужно установить дату, после которой обращение обуви без марок не разрешается. На момент написания статьи – это 1 июля 2020 г.

Теперь можно открыть РМК и начинать продажи.

Обувь без промышленного кода (EAN13) можно выбрать из справочника с помощью поиска по наименованию. До наступления даты ввода обязательной маркировки обуви ИС МП, программа не будет запрашивать код марки, но его можно ввести, воспользовавшись кнопкой нижней панели Марки. После критической даты программа попросит ввести марку, открыв форму подбора марок.

Если обувь имеет промышленный штрихкод EAN13, то считываем его сканером. При этом открывается форма ввода марки, которая в зависимости от текущей даты, выглядит по-разному.

Форма слева позволяет добавить товар в чек без ввода марки, а справа – вид формы после наступления даты запрета оборота без марок.

Наконец, если пара обуви имеет марку, то тоже возможно два варианта. Если кассир считает марку, которая эмитирована в ЛК или в программе 1С по упрощенному описанию, то программа попросит уточнить номенклатуру, выбрав ее из справочника.

Если же марка была привязана к определенному размеру артикула, то есть эмитирована из программы 1С по документу Пересчет товаров, то строка в чек добавится автоматически.

Заключение

Таким образом, способ введения в оборот маркированных остатков влияет на процесс оформления продажи в РМК.

Более простая в исполнении маркировка остатков по категориям снижает вероятность пересортицы при нанесении марок и трудоемкость процесса, ведь марки можно заказать по учетным остаткам, не проводя реальной инвентаризации.

Зато кассиру придется, как минимум, сканировать два штрихкода – промышленный и марки, или даже выбирать номенклатуру из справочника. Правда, ему и так приходилось это делать в случае отсутствия какой-либо маркировки.

Выбор за пользователем.

Источник: 1С:ИТС.

Источник: https://buh.ru/articles/documents/107530/

1С 8.2 — Печать штрихкода

1с добавление штрих кода. «1С:Розница»: осваиваем штрихкоды. Оправданность перемаркировки товаров собственными штрихкодами

Пример печати штрихкодов в табличном документе 1С:Предприятия 8.2 предназначен для самостоятельной модификации и для последующего применения в режиме управляемого приложения. Ниже приведены примеры для EAN-13, GS1-128, QR-кода и других распространенныхформатов штрихкодов.

Пожалуйста, обратите внимание — пример рассчитан на работу с ПО StrokeScribe версии 4.0.4 или старше.

Подготовка макета для вывода штрихкода

1. Создайте новый отчет в конструкторе 1С:Предприятия 8.2 и дайте ему имя ОтчетШтрихкод(это имя будет использовано в модуле ниже).

2. Для отчета ОтчетШтрихкод создайте макет табличного документа под именем МакетШтрихкод.

3. В макете создайте область произвольного размера с именем ОбластьШтрихкод.

4. Поместите в область картинку (меню Таблица->Рисунки->Картинка) с размерами будущего штрихкода. В свойствах картинки укажите имя — РисунокШтрихкод.

В результате всех действий должен получиться макет отчета, похожий на показанный на рисунке:

Модуль отчета

Добавьте приведенный ниже код в модуль отчета. Самостоятельно смодифицируйте пользовательский интерфейс отчета для вызова обработчика команды. Данная реализация модуля создает единичный QR-код и легко модифицируется под создание нескольких штрихкодов разных форматов внутри одной области.

&НаСервереФункция ДокНаСервере() ТабДок = Новый ТабличныйДокумент; Макет = Отчеты.ОтчетШтрихкод.ПолучитьМакет(«МакетШтрихкод»); Область = Макет.ПолучитьОбласть(«ОбластьШтрихкод»); //Обратите внимание на совпадение имен отчета, макета и области в модуле и в дизайне barcode = ПолучитьCOMОбъект(«»,»STROKESCRIBE.StrokeScribeClass.1″); //Вы не забыли установить StrokeScribe? ИмяФайла=ПолучитьИмяВременногоФайла(«wmf»); //Временный файл во временном каталоге с расширением .wmf barcode.Alphabet>=25;//QR CODE barcode.Text=»123ABCD»;//Данные для штрихкода код=barcode.SavePicture(ИмяФайла, 7, //7=WMF 100, //Ширина картинки штрихкода 100); //Высота штрихкода Если код0 Тогда //Проверка результата генерации штрихкода Сообщить(строка(код) + » — » + barcode.ErrorDescription); Возврат Ложь; КонецЕсли; //Убедитесь в совпадении имени объекта рисунка здесь и в дизайне рис=Область.Рисунки.РисунокШтрихкод; рис.РазмерКартинки=РазмерКартинки.Пропорционально; рис.Линия = Новый Линия(ТипЛинииРисункаТабличногоДокумента.НетЛинии); //Вокруг штрихкода не должно быть рамки рис.Картинка = Новый Картинка(ИмяФайла);//Загрузка картинки со штрихкодом //Указывается то же имя файла, что и в SavePicture ТабДок.Вывести(Область); УдалитьФайлы(ИмяФайла);//Стереть временный файл с картинкой Возврат ТабДок;КонецФункции &НаКлиентеПроцедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды) ТабДок1=ДокНаСервере(); Если ТабДок1Ложь Тогда ТабДок1.Показать(); КонецЕсли;КонецПроцедуры

Результат работы данного модуля — таблица с внедренной картинкой QR Code. Для выбора формата штрихкода, укажите другую константу в свойстве Alphabet. Для наиболее распространенных форматов штрихкодов ниже приведены специализированные примеры.

Замечания по модулю отчета:

Для успешного выполнения вызова ПолучитьCOMОбъект() не забудьте установить ПО StrokeScribe. При работе в режиме клиент-сервер, ПО StrokeScribe должно быть установлено на сервере. На клиентских ПК установка StrokeScribe не требуется.

Вызов ПолучитьИмяВременногоФайла() требуется для получения произвольного имени промежуточного файла, в котором будет сохранено изображение штрихкода перед передачей его в табличный документ. Файл должен существовать до вызова ТабДок.Вывести(Область).

После этого временный файл может быть удален. Если планируется создание нескольких штрихкодов в одной области, то для каждого штрихкода должен быть создан свой временный файл.

Так как SavePictureсохраняет штрихкод в формате WMF, то создаваемому файлу присваивается соответствующее расширение.

При желании, может быть использовано и фиксированное имя файла, например: ИмяФайла=»c:\temp\barcode.wmf». Разумеется, что папка «c:\temp» должна существовать и быть доступной для создания файлов.

Присваивание barcode.Alphabet= задает формат штрихкода. Константы типов штрихкодов доступны в документации. Примеры создания наиболее распространенных штрихкодов приведены ниже.

Данные, присваиваемые barcode.Text, зависят от формата штрихкода. Например, EAN-13 не может отображать буквы и имеет фиксированную длину, а CODE 128 не работает с кириллицей.

Если StrokeScribe не может обработать строку, то в свойство Error будет записано ненулевое значение.

В модуле используется упрощенная проверка ошибок — результат всех операций вместе помещается в переменную код: код=barcode.SavePicture().

Вызов SavePicture() сохраняет изображение штрихкода во временном файле. Указание 7 во втором параметре вызова SavePicture() создаст векторное масштабируемое изображение в формате WMF.

В коммерческой версии StrokeScribe доступны также форматы JPG, PNG, GIF, BMP24 и EMF.

Создание растровых изображений штрихкода не рекомендуется из-за большого объема данных и плохой приспособленности к масштабированию, но может применяться в случае, если тонкий клиент не поддерживает WMF.

В конструкции Если код0 проверяется результат сохранения картинки штрихкода в файле.

Код будет ненулевым и в том случае, если указан несуществующий тип штрихкода или в свойство Textпосланы данные, не отображаемые штрихкодом выбранного типа.

Текстовое пояснение к коду ошибки доступно в свойстве ErrorDescription. Результат каждой операции с объектом штрихкода можно дополнительно контролировать проверкой значения свойства Error.

Для вывода множества штрихкодов достаточно организовать циклическое присваивание Text=, Alphabet= (опционально) и обращение к методу SavePicture. Каждое обращение к SavePicture должно происходить с отдельным именем файла для каждого штрихкода внутри одной области до вызова ТабДок.Вывести(). После вывода области файлы могут быть удалены.

Примеры создания штрихкодов в отчете 1С 8.2

Ниже даны примеры создания некоторых распространенных форматов штрихкодов. Так как некоторые из форматов имеют дополнительные настройки, рекомендуем обратиться к страницам, ориентированным на определенный формат штрихкода (см. меню сайта слева) и к документации по свойствам StrokeScribe.

Пожалуйста, обратите внимание — версия 1С:Предприятия 8.2.12.96, на которой производилось тестирование, некорректно центрирует изображения WMF, сдвигая их вправо. Поэтому не рекомендуется уменьшать чистые зоны штрихкодов (свойства HBorderSize и QuietZone2D) во избежание потери части линий штрихкода.

EAN-13

Для вывода EAN-13, установите свойство Alphabet=3. В свойство Text запишите цифровой 12-значный код товара (или 13-значный, если известна контрольная сумма). Вычисление и проверка контрольной суммы выполняется автоматически. При передаче 13-значного кода с неверной контрольной суммой, соответствующий код ошибки будет выставлен в свойстве Error.

Смодифицируйте исходный текст модуля, как показано ниже:

barcode.Alphabet=3; //EAN13 barcode.Text=»123456789012″; код=barcode.SavePicture(ИмяФайла, 7, 100, 60);

CODE 128

Штрихкод CODE 128 формируется при установке свойства Alphabet=5. В свойство Text можно записать любые символы ASCII, в том числе и управляющие коды. Обратите внимание — CODE 128 не поддерживает кириллицу. При записи недопустимых символов в свойство Text, в свойстве Error будет выставлен соответствующий код ошибки.

Смодифицируйте исходный текст модуля, как показано ниже:

barcode.Alphabet=5; //CODE128barcode.Text=»123ABC» + Символ(9) + «def»; код=barcode.SavePicture(ИмяФайла, 7, 100, 60);

Символ(9) — функция языка 1C — кодирует символ табуляции (ASCII TAB). Все нечитаемые символы отображаются, как * в подписи под штрихкодом. CODE 128 позволяет задать произвольный текст подписи, который будет выведен под штрихкодом вместо стандартного отображения закодированных данных:

barcode.Alphabet=5; barcode.Text=»123ABC» + Символ(9) + «def»; barcode.TextBelow=»моя подпись»;

Формат штрихкода ITF-14 задается установкой свойства Alphabet=7. В свойство Text запишите цифровой 13-значный цифровой код (или 14-значный, если известна контрольная сумма). Вычисление и проверка контрольной суммы выполняется автоматически. При передаче 14-значного кода с неверной контрольной суммой, соответствующий код ошибки будет выставлен в свойстве Error.

Смодифицируйте исходный текст модуля, как показано ниже:

barcode.Alphabet=7; //ITF14barcode.Text=»1234567890123″;barcode.ITF14BearerBox=1; код=barcode.SavePicture(ИмяФайла, 7, 100, 30);

Свойство ITF14BearerBox выводит ITF-14 с прямоугольной рамкой, обычно присутствующей на штампах для гофрированной тары. Для вывода штрихкода только с горизонтальными защитными линиями, укажите ITF14BearerBox = 0.

GS1-128 (ранее EAN-128)

Для печати штрихкода GS1-128, установите свойство Alphabet=17. В свойство Text запишите последовательность данных и идентификаторов AI.

Пример: идентификатор партии = 1234; масса брутто = 12345.6Кг; годность до 17/05/2001. Результирующая строка: «10» + «1234» + GS + «3301» + «123456» + «17» + «010517».

Для ограничения параметров переменной длины используется ASCII GS (десятичный код 29).

Смодифицируйте исходный текст модуля, как показано ниже:

barcode.Alphabet=17; //EAN128GS = Символ(29);barcode.Text=»10″ + «1234» + GS + «3301» + «123456» + «17» + «010517»;barcode.ITF14BearerBox=1; код=barcode.SavePicture(ИмяФайла, 7, 100, 30);

Большие объемы данных в формате GS1 можно хранить в двумерных штрихкодах GS1 DATAMATRIX.

Data Matrix

Формат штрихкода Data Matrix задается установкой свойства Alphabet=8. Data Matrix позволяет кодировать любые данные, включая двоичные.

Передача кириллицы в кодовой странице CP1251 не разрешается стандартом, но фактически используется в штрихкодах Почты России и некоторых банков.

Создание Data Matrix, содержащих ECI=22 допустимо, если достоверно известно, что сканирующее оборудование и считывающее ПО поддерживают ECI. Для распознавания Data Matrix с кириллицей на мобильных телефонах, требуется кодирование в UTF-8.

Смодифицируйте исходный текст модуля, как показано ниже:

barcode.Alphabet=8; //DATAMATRIXbarcode.Text=»123abcDEF»; код=barcode.SavePicture(ИмяФайла, 7, 100, 100);

Aztec

Штрихкод Aztec задается установкой свойства Alphabet=33. Aztec позволяет кодировать любые данные, включая двоичные. Кириллица в кодовой странице CP1251, по установившейся практике, передается в режиме кодирования двоичных данных.

Стандарт требует указания идентификатора ECI=22 перед использованием кириллицы, но тем не менее, не все современное оборудование и ПО поддерживают ECI.

Распознавание Aztec не поддерживается почти всеми мобильными телефонами, за исключением специализированных моделей для складского применения.

Для печати кода Aztec, смодифицируйте исходный текст модуля, как показано ниже:

barcode.Alphabet=33; //AZTECbarcode.Text=»123ABcd»; код=barcode.SavePicture(ИмяФайла, 7, 100, 100);

QR Code

QR Code генерируется при установке свойства Alphabet=25. Данный формат позволяет кодировать текстовые и двоичные данные.

Кодирование кириллицы для распознавания на мобильных телефонах должно осуществляться в кодировке UTF-8.

Применение идентификаторов ECI должно осуществляться только при уверенности, что считывающее оборудование и ПО поддерживают индикацию ECI. Для изменения уровня коррекции ошибок используйте свойство QrECL.

Приведенный здесь пример предназначен для создания QR-кода для мобильных приложений. Большинство складских и офисных применений в России (при распознавании специализированными сканерами) требуют прямой передачи текста в кодовой странице CP1251. Для этого установите UTF8=0. Установка QrECL приведена здесь в качестве примера и не является обязательной.

barcode.Alphabet=25; //QRCODEbarcode.Text=»кириллица»;barcode.UTF8=1;barcode.QrECL=2; код=barcode.SavePicture(ИмяФайла, 7, 100, 100);

Если у вас не получилось, то наш специалист может приехать и решить задачу.

Настроим. Подключим. Исправим. Найдем ошибку 1с.

«1С:Упрощенка 8» является спец-поставкой программы «1С:Бухгалтерия 8. Базовая версия», которая предварительно настроена для ведения учета по УСН. При этом в «1С:Упрощенке 8» сохранены все возможности «1С:Бухгалтерии 8» – достаточно изменить настройку и можно вести полноценный учет для организаций, применяющих общий режим налогообложения и уплачивающих налог на прибыль.

«Программа 1С Бухгалтерия 8 создана для автоматизации бухгалтерского и налогового учета, включая подготовку обязательной регламентированной отчетности, на коммерческих предприятиях: оптовую и розничную торговлю, комиссионную торговлю, оказание услуг, производство и тому подобное.

Программа «1С:Предприниматель 8» — создана для ведения бухгалтерского учета и составления отчетности индивидуальными предпринимателями ИП, ЧП, ПБОЮЛ. Программа позволяет вести Книгу учета доходов и расходов и хозяйственных операций индивидуальных предпринимателей, являющихся плательщиками налога на доходы физических лиц (НДФЛ).

При необходимости работать с программой 1С более чем на одном компьютере (это может быть локальная сеть), а также при работе в одной базе 1С, возникает необходимость купить лицензии 1С. Лицензии 1С — это дополнительные ключи защиты программ 1С, которые покупаются отдельно и дают право пользоваться на несколько компьютеров.

Источник: https://center-comptech.ru/articles/st_011113-5.html

Штрихкодирование документов в 1С 8.3 (8.2)

1с добавление штрих кода. «1С:Розница»: осваиваем штрихкоды. Оправданность перемаркировки товаров собственными штрихкодами

Рассмотрим подключение подсистемы штрихкодирования документов на примере подключения такого механизма в конфигурации 1С 8.2 и 8.3 Управление торговлей.

Зачем нужно штрихкодирование документов в 1С?

Штрихкодирование документов может понадобиться для наведения порядка в бумажном документообороте — любому бумажному документу за считанные секунды можно найти электронный аналог в системе. Например, очень удобно, когда клиенты приходят в офис с уже распечатанным заказом, в котором есть штрих-код, — в этом случае обслуживание клиента занимает существенно меньше времени.

Настройка штрихкодирования документов 1С

Первый шаг к настройке штрихкодирования — создание штрих-кода, хранение его в базе данных и распечатка на бумажном носителе.

Генерация штрих-кода и сохранение его в 1С

Для хранения штрих-кода создадим у документа новый реквизит — назовём его «штрихкод».

С генерацией нового штрих-кода немного труднее. Необходимо воспользоваться процедурой РаботаСТорговымОборудованием.СформироватьШтрихКод() из конфигурации управление торговлей и сформировать его перед записью нового документа:

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения) ….. Если ЭтоНовый() Тогда Штрихкод = РаботаСТорговымОборудованием.СформироватьШтрихКод(); КонецЕсли; ….. КонецПроцедуры;

Распечатка штрих-кода на печатной форме описана в отдельной статье — вывод на печатную форму штрих-кода.

Если вы только начинаете программировать в 1С или просто хотите систематизировать свои знания — попробуйте Школу программирования 1С нашего друга Владимира Милькина. Пошаговые и понятные уроки даже для новичка с поддержкой учителя.
Попробуйте бесплатно по ссылке >>

С установкой, хранением и распечаткой документов мы разобрались. Перейдем к другому этапу — поиск документов по штрих-коду.

Настройка поиска документа в 1С по штрих-коду

Рассмотрим поиск документа по штрих-коду из формы списка документа «Заказ покупателю».

Первым делом необходимо скопировать из других форм (например, форма списка номенклатуры), отвечающих за работу с внешним оборудованием — сканером штрих-кода. Вот процедуры, которые необходимо поместить в форму списка:

Процедура ВнешнееСобытие(Источник, Событие, Данные) ПолучитьСерверТО().ОбработатьВнешнееСобытие(Источник, Событие, Данные, ЭтаФорма); КонецПроцедуры Функция ПоддерживаетсяВидТО(Вид) Экспорт Результат = Ложь; Если Вид = Перечисления.ВидыТорговогоОборудования.

СканерШтрихКода Тогда Результат = Истина; КонецЕсли; Возврат Результат; КонецФункции // ПоддерживаетсяВидТО() Функция СШКНоменклатура(Номенклатура, Характеристика, Серия, Качество, Единица, Количество, СШК) Экспорт Результат = Истина; Возврат Результат; КонецФункции // СШКНоменклатура() Функция СШКСерийныйНомер(Номер, СШК) Экспорт Возврат Истина; КонецФункции // СШКСерийныйНомер() Функция СШКИнформационнаяКарта(Карта, СШК) Экспорт Результат = Истина; Возврат Результат; КонецФункции // СШКИнформационнаяКарта() Функция СШКНеизвестныйКод(Штрихкод, ТипКода, СШК) Экспорт НайтиЗаказПоШтрихкоду(Штрихкод); Возврат Истина; КонецФункции // СШКНеизвестныйКод() Процедура СШКОшибка(Ошибка, Штрихкод, ТипШК, СШК) Экспорт Текст = ПолучитьСерверТО().ПолучитьТекстОшибкиСШКТО(Ошибка, Штрихкод, ТипШК); Предупреждение(Текст); КонецПроцедуры // СШКОшибка()

Обратите внимание на процедуру СШКНеизвестныйКод, если стандартные механизмы не смогли найти номенклатуру, они вернут нас в функцию «СШКНеизвестныйКод», где мы его и обработаем.

Опишем процедуру НайтиЗаказПоШтрихкоду, с помощью которой мы найдем нужный документ по штрих-коду и откроем его форму:

Процедура НайтиЗаказПоШтрихкоду(ТекШтрихкод) Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | ЗаказПокупателя.Ссылка |ИЗ | Документ.ЗаказПокупателя КАК ЗаказПокупателя |ГДЕ | ЗаказПокупателя.Штрихкод= &Штрихкод»; Запрос.УстановитьПараметр(«Штрихкод», ТекШтрихкод); Результат = Запрос.Выполнить(); Если Результат.

Пустой() Тогда Сообщить(«Заказ с штрихкодом » + ТекШтрихкод + » не найден»); Возврат; Иначе Выборка = Результат.Выбрать(); Выборка.Следующий(); СсылкаНаДокумент = Выборка.Ссылка; СсылкаНаДокумент.ПолучитьФорму().Открыть(); КонецЕсли; КонецПроцедуры

При выполнении данной процедуры будет происходить поиск нужного заказа по штрих-коду.

Если заказ найден по штрих-коду, то система откроет заказ, не найден — сообщит об этом.

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

Источник: https://programmist1s.ru/poisk-dokumentov-po-shtrihkodu-v-1s/

Печать штрихкодов в 1С. Подробная инструкция

1с добавление штрих кода. «1С:Розница»: осваиваем штрихкоды. Оправданность перемаркировки товаров собственными штрихкодами

Как в 1С вывести на печать штрихкод? Что необходимо установить и настроить для этого? Предлагаем нашим читателям подробную инструкцию по установке компоненты, добавлению штрихкода в ценник, созданию макета и вывода его на печать.

Установка компонента 1С Печать штрихкодов

Для вывода в 1С штрихкода в печатную форму предназначен объект «1С:Печать штрихкодов». Данный элемент управления предназначен для формирования штрихкодов следующих форматов:

EAN8, EAN13, EAN13 AddOn 2, EAN13 AddOn 5, ITF14, RSS14, EAN128, Code39, Code39 Full ASCII, Code93, Code128, Code16k, Industrial 2 of 5, Interleaved 2 of 5, CodaBar, PDF417.

В нем поддерживается автоопределение формата штрихкода, возможность передавать символьное значение штрихкода как с контрольным символом, так и без него, а также можно отключать показ контрольного символа штрихкода на результирующем изображении штрихкода.

Если данный элемент не установлен у вас не установлен, то при попытке сделать печать вы увидите ошибку с текстом: «Компонента печать штрихкодов 1С не установлена на данном компьютере». В таком случае перед следующими шагами вам необходимо установить элемент. Выберите его на сайте и установите на ПК.

Установка максимально простая, поэтому просто следуйте указаниям:

Печать штрихкодов на ценниках в 1С

Для примера предлагаем рассмотреть печать штрихкода в«1С:Розница». Обратимся к пункту «Цены номенклатуры» и рассмотрим вывод на печать ценников товаров, на которые уже назначена цена.

Печать ценников и этикеток доступны из документа «Установка цены номенклатуры» в кнопке «Печать»:

В обработке уже будут выбраны товары, поэтому нам нужно будет задать «Шаблон ценника». Если заранее такой шаблон не был подготовлен, то создайте его на этом шаге.

Нажав кнопку «Редактировать макет», переходим в редактор шаблонов и выбираем «Загрузить шаблон по умолчанию».

Выбрав созданный шаблон, выделяем необходимые товары и нажимаем кнопку «Печать».

Штрихкод 1С в макете печатной формы

Вы можете самостоятельно разработать макет печатных форм с использованием штрихкода. В конфигураторе открываем макет печатной формы нужного документа и переходим в меню:

Таблица — Рисунок — Вставить объект

В появившемся окне переключаем указатель в положение «Элемент управления» и мы видим, что появился тип объекта «1С.V8. Печать штрих-кодов».

Помощь профессионалов

Если у вас нет достаточно компетентных сотрудников или у ваших специалистов сейчас есть более важные задачи, мы предлагаем обратиться за помощью к специалистам компании «ПРОГРАММЫ 93»!

Как мы можем помочь вам в работе с 1С?

  • Решение конкретных задач. Сложности при работе с программой, ошибки, установка и настройка 1С и многое другое.
  • Полное сопровождение 1С. Мы обеспечиваем надежную работу продукта и оперативное решение всех возникающих вопросов и проблем.
  • Разработка под 1С.

     После уточнения ваших целей и задач, мы предлагаем и разрабатываем индивидуальное решение.

  • Интеграция сайта с 1С. Возможность вывести бизнес на новый уровень и оптимизировать бизнес-процессы.

Позвоните по номеру телефона, указанному на сайте или заполните форму обратной связи, чтобы мы могли сориентировать по стоимости и рассказать, как начать сотрудничество.

14 июня 2020

Page 3

Виды программ 1С

Вы подбираете подходящий продукт для своей компании? Еще не пользовались 1С или возникла необходимость в смене версии? Мы расскажем о том, какие бывают программы 1С, чем они отличаются друг от друга и в каких случаях, какие продукты подойдут лучше всего.

27 декабря 2018

Page 4

23 декабря 2018

Подключение онлайн касс к 1С

Подключение онлайн кассы к 1С удобно не только с точки зрения отчетности и оптимизации работ, но и для дополнительной аналитики, которая может реально помочь вашему бизнесу. Сегодня мы расскажем, как в 1С подключить ККС онлайн самостоятельно и что можно сделать, чтобы решать подобные задачи наиболее эффективно и в короткие сроки.

Page 6

23 декабря 2018

Подключение онлайн касс к 1С

Подключение онлайн кассы к 1С удобно не только с точки зрения отчетности и оптимизации работ, но и для дополнительной аналитики, которая может реально помочь вашему бизнесу. Сегодня мы расскажем, как в 1С подключить ККС онлайн самостоятельно и что можно сделать, чтобы решать подобные задачи наиболее эффективно и в короткие сроки.

Page 7

Источник: https://1c.programs93.ru/articles/pechat-shtrihkodov-v-1s-instrukcija/

Вопросы адвокату
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: